Removing Duplicate RPM Packages

My OEL4 servers still have duplicate RPM packages on 64 bit servers. Libs for 32 bit and 64 bit are often installed, even though they may not always be used. When upgrading a package, such as glibc, you run into the error that yum won't touch a package because it finds duplicates.

In this case you can try Removing Duplicate RPM Packages or remove a package using an explicit architecture tag:
yum package.{i386,i686,x86_64} such as yum remove glibc.i686.

If you have RHEL/OEL5 or higher, you're in luck because you can try to install the package yum-utils and run package-cleanup --cleandupes. yum-utils offer a bunch of useful tools for working with yum repos and so on.

No comments: